Eclipse - RとLinuxと...

RとLinuxと...


Eclipse

Eclipse の備忘録

_ プロジェクト作成

  1. とりあえず,適当なプロジェクトを作成する.main 関数の作成オプションを指定し,さらに
    [Project Layout] - [Create Separate source and output folder]
    [allow output folder for source folders]
    を選択しておく.まずメインとなるクラスファイルを作成する.
  2. 作成されたクラスで,別名のクラスのオブジェクトを作成する記述を書く.
  3. すると,ウィンドウ左に赤いチェックが付くので,右クリックすれば,その名前のクラスを作成する異ができる.
  4. ここで必要があれば,スーパークラスやインターフェイスを指定しておく.ここではSwing プログラムを作成するものとする.
  5. まずはコンストラクタの用意.
    [source] - [Geneate Constructors from Superclass...] を使っても良い.
  6. コンストラクタ内で
    1. 生成するウィンドウサイズの設定
      setSize(300,200);
      setTitle("Swing  サンプル");
      setLocation(210,415);
    2. 作成するウィンドウ内のパネルを用意する.
      JPanel p = new JPanel();
      ウィンドウ左に赤いマーカが出るので,JPanel クラスをインポートする
  7. パネルのレイアウトとテキストフィールドを設定
    p.setLayout(new BoxLayout(p, BoxLayout.Y_AXIS));
    text1 = new JTextField("身長を入力(単位cm)");
    text2 = new JTextField("体重を入力(単位kg)");
  8. パネルに載せる
    p.add(text1);
    p.add(text2);
    getContentPane().add(p);
  9. メニューを追加して,アクションリスナーを追加
    JMenuBar menuBar = new JMenuBar();
    setJMenuBar(menuBar);
    
    JMenu file = new JMenu("ファイル",true);
    menuBar.add(file);
    
    savelog = new JMenuItem("ログを保存");
    savelog.addActionListener(this);
    file.add(savelog);
    
    close = new JMenuItem("閉じる");
    close.addActionListener(this);
    file.add(close);
    
    JMenu cal = new JMenu("計算",true);
    menuBar.add(cal);
    
    calBMI = new JMenuItem("BMIの計算");
    calBMI.addActionListener(this);
    cal.add(calBMI);			
  10. 最後に表示の設定をして,コンストラクタ終了.
    setVisible(true);	
  11. イベントの処理を記述
    public void actionPerformed(ActionEvent arg0) {
     JMenuItem chosen = (JMenuItem)  arg0.getSource();
     String str1 = text1.getText();
     String str2 = text2.getText();
     
    JOptionPane.showMessageDialog(this,str1,str2,
    			JOptionPane.INFORMATION_MESSAGE);
    }

改訂版Eclipseの導入ガイド p.196 より

_ Document 自動生成

一通り関数を作成したら,その関数の実装部分の上で

/**

と入力して( /* ではない),エンターを押すと,自動的にパラメータ等を追記したコメント領域を作成してくれる.

/**
	* @param args 身長 体重
*/

などと記述する. Document の生成は

[エクスポート] - [java] - [Javadoc]

javadoc command に明示的に以下を与える

/usr/bin/javadoc

するとプロジェクトの doc フォルダに index.html をはじめとしたファイル群が作成される.設定は

[ウィンドウ] - [設定] -[java] -[Compiler] - [Javadoc]

_ 引数を与える

[Run] - [構成および実行]

で [名前] に当該プロジェクトが選択されているのを確認の上,Arguments タブ,Program arguments にスペースで区切って追加する.

_ 例外の処理

例外が予想される部分の範囲指定して,

[Source] - [Surround With] - [Try Catch Block]

を選択すれば良い.

_ jar ファイルの作成

当該プロジェクトを右クリックし,

[エクスポート] - [java] -[JarFile]

マニフェスト作成設定ダイアログ下でメインクラスの指定を忘れてはいけない. 念のため実行方法は hoge.jar に引数を二つ与えるのであれば

$java -jar hoge 182 58
 
添付ファイル: filesaveFile.java 347件 [詳細] fileRunSwing.java 349件 [詳細] fileMainWindow.java 365件 [詳細] fileCalculateBMI.java 360件 [詳細]
Last-modified: 2007-11-09 (金) 19:07:24 (4180d)